• 中文
    • English
  • 注册
  • BBS 易源码 关注:1 内容:36

    随机生成MAC地址源码

  • 查看作者
  • 打赏作者
  • 拉黑名单
  • Lv.4
    VIP
    管理员

    随机生成MAC地址源码

    每块网卡生产出来后,都会有一个全球唯一的编号来标识自己,不会重复,这个编号就是MAC地址,也就是网卡的物理地址

    查阅了一些资料,16进制中第一组第二个数字一定是个偶数(十进制概念,不知道恰不恰当)

    也就是说第二个数字一定是0、2、4、6、8、A、C、E其中的一个

    源码原理

    取随机数字16-255,判断是否为偶数不是就+1,这样第一组就出来了

    然后用取十六进制文本将10进制转换成16进制,再循环随机5组就实现了取随机MAC地址

    .版本 2
    
    .子程序 文本_取随机MAC, 文本型, , 随机返回一个MAC地址 如:F8:1F:CC:C2:AF:14
    .局部变量 临时整数, 整数型
    .局部变量 l1, 整数型
    .局部变量 MAC, 文本型
    
    .计次循环首 (6, l1)
        置随机数种子 ()
        临时整数 = 取随机数 (16, 255)  ' 代表16进制的00-FF范围
        .如果真 (l1 = 1)
            .如果真 (临时整数 % 2 = 1)  ' 取随机数后判断是否为偶数不是就+1
                .判断开始 (临时整数 = 255)
                    临时整数 = 临时整数 - 1
                .默认
                    临时整数 = 临时整数 + 1
                .判断结束
    
            .如果真结束
    
        .如果真结束
        .判断开始 (l1 = 6)  ' 判断否是最后一组是就不加分隔符
            MAC = MAC + 取十六进制文本 (临时整数)
        .默认
            MAC = MAC + 取十六进制文本 (临时整数) + “:”
        .判断结束
    
    .计次循环尾 ()
    返回 (MAC)

    隐藏内容需要登录才可以看见

    登录

    请登录之后再进行评论

    登录
  • 做任务
  • 实时动态
  • 偏好设置
  • 签到中心
    偏好设置
    在线聊天
  • 返回顶部
  • 帖子间隔 侧栏位置: