• 中文
    • English
  • 注册
  • BBS 易源码 关注:1 内容:36

    文本_HEX转ASCII源码

  • 查看作者
  • 打赏作者
  • 拉黑名单
  • Lv.4
    VIP
    管理员
    .版本 2
    
    .子程序 文本_HEX转ASCII, 文本型, 公开, 将OD里的HEX数据转换为ASCII字符串。D0C5CFA2B4EDCEF3-->"信息错误"
    .参数 十六进制文本, 文本型
    .局部变量 字节集, 字节集
    .局部变量 i, 整数型
    .局部变量 格式转换, 文本型
    
    字节集 = 字节集_还原 (十六进制文本)
    .计次循环首 (取字节集长度 (字节集), i)
        .如果真 (字节集 [i] = 0)
            字节集 [i] = 10
        .如果真结束
    
    .计次循环尾 ()
    格式转换 = 到文本 (字节集)
    返回 (格式转换)

    将OD里的HEX数据转换为ASCII字符串。D0C5CFA2B4EDCEF3-->"信息错误"

    隐藏内容需要登录才可以看见

    登录

    请登录之后再进行评论

    登录
  • 做任务
  • 实时动态
  • 偏好设置
  • 签到中心
    偏好设置
    在线聊天
  • 返回顶部
  • 帖子间隔 侧栏位置: