• 中文
    • English
  • 注册
  • BBS 易源码 关注:1 内容:36

    易语言字节集对比源码

  • 查看作者
  • 打赏作者
  • 拉黑名单
  • Lv.4
    VIP
    管理员

    易语言字节集对比源码

    可以对比两个字节集的差异,且提取差异内容

    .版本 2
    .支持库 commobj
    
    .子程序 字节集比较, 整数型
    .参数 字节集1, 字节集
    .参数 字节集2, 字节集
    .参数 比较结果, 文本型, 参考
    .局部变量 结果, 快速文本对象
    .局部变量 长度, 整数型
    .局部变量 n, 整数型
    .局部变量 count, 整数型
    
    长度 = 选择 (取字节集长度 (字节集1) < 取字节集长度 (字节集2), 取字节集长度 (字节集1), 取字节集长度 (字节集2))
    结果.添加 (“偏移” + 字符 (#Tab键) + “字节集1” + 字符 (#Tab键) + “字节集2” + #换行符)
    .计次循环首 (长度, n)
        .如果真 (字节集1 [n] ≠ 字节集2 [n])
            count = count + 1
            结果.添加 (到文本 (n) + 字符 (#Tab键) + 到文本 (字节集1 [n]) + 字符 (#Tab键) + 到文本 (字节集2 [n]) + #换行符)
        .如果真结束
    
    .计次循环尾 ()
    比较结果 = 结果.取文本 (, )
    返回 (count)

    隐藏内容需要回复可以看见

    回复

    请登录之后再进行评论

    登录
  • 做任务
  • 实时动态
  • 偏好设置
  • 签到中心
    偏好设置
    在线聊天
  • 返回顶部
  • 帖子间隔 侧栏位置: